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Abbreviations 
CRP Calibrated Reflectance Panel 

DJI SZ DJI Technology Co., Ltd.  

GCP Ground Control Point 

GNSS Global Navigation Satellite System  

GPS Global Positioning System 

RGB  Red, Green, Blue 

RTK Real Time Kinematic  

UAS Unoccupied Aircraft System 
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Scope 
This document describes the UAS data processing workflow developed for RGB and multispectral 

imagery simultaneously collected on DJI Matrice 300 (M300) RTK platform. The workflows outlined 

in this document are designed for use with RGB imagery acquired with DJI Zenmuse P1 camera and 

multispectral imagery from MicaSense RedEdge-MX or Dual sensors (see ‘Drone Data Collection 

Protocol’ on the TERN protocols page). The M300 is equipped with GNSS RTK (Global Navigation 

Satellite System Real Time Kinematic) which can be used with the D-RTK 2 base station to determine 

the position of the UAS with centimetre-level accuracy. This enables high georeferencing accuracy 

without the use of ground control points (GCPs) or ground surveys. This protocol describes two 

approaches to processing RGB and multispectral imagery using Agisoft Metashape Pro: 

1. Automated processing using a Python workflow  

• The workflow is described in ‘Summary of processing workflow using Agisoft 

Metashape’.  

• User input is required to select images for MicaSense reflectance calibration.  

• Equivalent Metashape toolbar commands are listed for all steps.  

• A prototype to create a custom widget in Agisoft Metashape for the same workflow 

is described is ‘Appendix 6: Processing workflow using a custom Metashape 

window’. 

2. Step-by-step workflow using the Metashape graphical user interface (GUI)  

The primary data products from this workflow are co-registered RGB and multispectral 

orthomosaics.  

https://www.tern.org.au/field-survey-apps-and-protocols/


 
 

Summary of processing workflow using Agisoft Metashape 
Table 1: Summary of automated processing workflow on Agisoft Metashape Pro 

 

 

 

  

# Chunk Processing Step Metashape Menu Summary 

1 N/A Metashape Preferences Tools -> Preferences 

General: Update ‘Theme’ to Classic 
Advanced 

• Keep depth maps, Strip file extensions from camera labels, Load camera calibration from XMP meta data, Load camera 
orientation angles from XMP meta data 

• Enable rich Python console 

2 N/A 
Save Metashape project as .psx 

file 
File –> Save As 

 
Suggested naming: ‘YYYYMMDD_ PlotName.psx’ (YYYYMMDD – date of data collection).  
 
Save project in imagery/metashape/ within the TERN plot folder.  
 

Run script to add RGB and multispectral imagery and to start the processing workflow.  See Table 2 for steps completed in the script. 
 

3 N/A 
Process rgb and multispec 

chunks to generate 
orthomosaic tiff 

Tools -> Run Script 
(metashape_proc.py) 

Note: One-time setup required to install extension python packages listed in ‘Agisoft Metashape setup’. 
 
Script name: metashape_proc.py 
Required argument: -crs “EPSG code for target projected coordinate system” 
(Find the EPSG code of the coordinate system.) 
 
Optional arguments (see ‘Appendix 1: Note on Folder Structure’ for information on default path arguments) 

i. -multispec “path to multispec image folder”  
Default is relative to project location: ../multispec/level0_raw/   

ii. -rgb <path to p1 images” 
Default is relative to project location: ../rgb/level0_raw/   

iii. Strength value to smooth P1 model. "-smooth <low/medium/high>". Default is low. 
Low: for low-lying vegetation (grasslands, shrublands), Medium and high: as appropriate for forested sites. 

iv. If blockshift of rgb coordinates required (see following sections for details):  
-drtk “path to txt file with DRTK coords” 

 
Outputs/intermediate files and location: 

i. P1 orthomosaic tiff (imagery/rgb/level1_proc/) 
ii. MicaSense orthomosaic (imagery/multispec/level1_proc/) 

iii. CSV of updated positions for rgb (if blockshifted) and micasense (imagery/metashape/) 
iv. Smoothed RGB model used as orthorectification surface for both p1 and micasense (imagery/metashape/) 

 

Script paused for user to complete the following steps  

4 multispec Locate panels 
Select ‘multispec’ chunk in Workspace 

pane. 
Tools -> Calibrate Reflectance 

• Click ‘Locate Panels’ to move images of MicaSense calibration Panel to camera group ‘Calibration Images’ and to 
automatically set the panel mask.  

• After images have been identified, press ‘Cancel’. Panel mask must be inspected before reflectance calibration. 

5 multispec 
Expand ‘Calibration images’ 

folder under ‘Cameras’ 
NA 

• On the Workspace pane, inspect images in ‘Calibration Images’ to identify images to be used (from either before or after 
flight). Select images that are not to be used for calibration. Right-click and ‘Remove Cameras’.  

• Open a calibration image. Click on the ‘Show Masks’ icon. Only the panel must be unmasked.  

• If the default mask is not set correctly, fix it manually as follows: 
o Click on ‘Rectangle selection’, right click on calibration image in the main window, ‘Reset Mask’, select panel area 

using ‘Rectangle selection’, ‘Add Selection’. This will set the panel area to be masked. Now select ‘Invert Mask’. 
o Repeat this for other channels (change the channel displayed using Tools -> Set Primary Channel).   
o Repeat for all images. 

6 Click on ‘Resume Processing’ in the toolbar to complete the processing workflow. See Table 2 for more information. 

https://epsg.org/home.html


 
 

Table 2: Summary of steps completed in Python script metashape_proc.py and equivalent commands on Metashape GUI. 

Chunk Processing step Equivalent step on Metashape GUI 
Summary 

 
For more information on Metashape commands refer to the Metashape Pro User Manual (Agisoft 2022a) 

NA Add Chunk Workspace pane 
Right-click and select ‘Add Chunk’ and rename as ‘rgb’ 

rgb Add images Workflow -> Add Folder 
Navigate to folder containing images and select all images to be added. Select ‘Single cameras’ 

NA Add Chunk Workspace pane 
Right-click and select ‘Add Chunk’ and rename as ‘multispec’ 

multispec Add images Workflow -> Add Folder 
First double click on multispec chunk to make it active. 
Select toolbar command and navigate to folder (with subfolders) of all MicaSense images. 
In the next dialog, select ‘Multi-camera system’ option. 

multispec 
Locate panels,                        

Select Calibration images 
Tools -> Calibrate Reflectance User input to select micasense calibration images (Table 1) 

rgb 
 

If blockshift enabled Update P1 Camera positions 
Calculate difference between D-RTK2 base station position recorded on field and that from AUSPOS.  
Apply difference to all cameras. Convert CRS to target projected CRS. Save shifted_p1_pos.csv in project folder. 

Estimate Image Quality Photos pane – context menu 
Right click on an image from the context menu, select ‘Estimate Image Quality’ – and Apply to ‘All images’.  
Remove Images with Quality < 0.7 (Hardcoded value). 

Camera calibration Tools -> Camera calibration 
Lever-arm offsets (m) for p1 from single gimbal position:  0.087, 0.0, 0.0 (m) 
(Under GPS/INS Offset, ‘Enable Reference’ under Reference Column, and enter above values for X, Y, Z). 

Set camera accuracy Reference pane - Settings Under ‘Measurement Accuracy’ set Camera accuracy (m) to 0.1 m 

Align Photos Workflow -> Align Photos 
Settings - Accuracy: High, Generic preselection – unchecked, Reference preselection: Source.  

Optimise alignment Reference pane – Optimize Cameras Default settings (Following are unchecked: Fit b1, b2, k4 & all Advanced) 

Build dense cloud Workflow -> Build Point Cloud 
Set Quality: Medium, Depth Filtering: Mild. 
Note: On Metashape v1.x.x the point cloud is referred to as Dense Cloud. 
 

Build Mesh Workflow -> Build Mesh 
Set Source data: Point cloud, Surface type: Height field, Face count: Medium.  
 

Decimate mesh Tools->Mesh->Decimate Mesh Decimate model to half of original face count. 

Smooth mesh Tools -> Mesh -> Smooth Mesh 
Strength: 50 (low), 100 (medium), 200 (high). 
Note that settings are yet to be tested in sites with complex/dense vegetation. 
 

Export Model Workspace pane – 3D Model context menu 
Export model – necessary so that it can be used as surface for multispec chunk. Model exported in target CRS. 
Naming: <proj_name> _rgb_smooth_<strength_value>.obj 
 

Build orthomosaic Workflow -> Build Orthomosaic Set Surface: Mesh. Refine seamlines: True. 

Export orthomosaic Workspace pane – Orthomosaic context menu 

 
 
Pixel size rounded to 2 decimal places. 
Big Tiff, Tiled, overviews enabled. 
Naming: <proj_name>_rgb_ortho_<resolution_in_m>.tif 
 



 
 

 

Chunk Processing step Equivalent step on Metashape GUI 
Summary 

 
For more information on Metashape commands refer to the Metashape Pro User Manual (Agisoft 2022a) 

multispec 

Interpolate micasense 
image position 

Tools->Run Script  

metashape_upd_cam_pos_only.py 

 
Micasense and p1 mage timestamps used to interpolate micasense camera position. 
Updated micasense positions saved in interpolated_micasense_pos.csv in project folder. 
Remove cameras that triggered outside flight area. Load updated camera positions in chunk. 

Camera Calibration Tools -> Camera calibration 

Lever-arm offsets (m) for MicaSense sensor (in Gimbal 2) from single gimbal position: 
RedEdge-MX: -0.097, -0.03, -0.06 
MicaSense Dual: -0.097, 0.02, -0.08 

Set camera accuracy 
 

Reference pane - Settings 
Under ‘Measurement Accuracy’ set Camera accuracy (m) to 0.1 m 

Estimate Image Quality Photos pane – context menu 
Estimate Image Quality from the context menu.  
Remove Images with Quality < 0.7 (Hardcoded value). 

Set Primary Channel 
Set Brightness 

 

Tools -> Set Primary Channel 
Tools-> Set Brightness 

Set NIR as Primary Channel. Set optimal Brightness values for better display of images.  

Raster transform Tools -> Set Raster Transform Relative reflectance values, B1 is B1/32768 for band 1 and repeat for all bands.  

Reflectance Calibration Tools -> Calibrate Reflectance Check ‘Use reflectance panels’ and ‘Use sun sensor’. Click OK. 

Align Photos Workflow -> Align Photos Settings - Accuracy: High, Generic preselection – unchecked, Reference preselection: Source.  

Optimise alignment Reference pane – Optimize Cameras 
Default settings. 
(Following are unchecked: Fit b1, b2, k4 & all Advanced) 

Import Model File –> Import –> Import Model 
Import rgb model created earlier. Import model in the target CRS (was exported likewise). 
 

Build orthomosaic Workflow -> Build Orthomosaic Set Surface: Mesh.  Refine seamlines: True. 

Export orthomosaic Workspace pane – Orthomosaic context menu 

Pixel size rounded to 2 decimal places. 
Big Tiff, Tiled, overviews enabled. 
Naming: <proj_name>_multispec_ortho_<resolution_in_m>.tif 
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Agisoft Metashape setup 

Update Preferences 
1. Open Agisoft Metashape Pro. Access Tools –> Preferences. 

2. In the General tab, update Theme to ‘Classic’. Select ‘Write log to file’ and browse to enter 

the path and a name for the .txt file. 

 

Figure 1: Update Metashape Preferences. Select theme 'Classic' for display to match the screenshots in this document. 
Choose a path to save the log file. 

3. In the GPU tab, make sure all GPUs are selected. Uncheck the box ‘Use CPU when 

performing GPU accelerated processing’. 

 

Figure 2: When using dedicated GPUs disable integrated CPU and GPUs. In the GPU tab, disable the option 'Use CPU...' as 
shown above. 
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4. In the Advanced tab, ensure that the following settings are checked.  

Project Files: 

- Keep depth maps (see note below) 

Export/Import: 

- Strip file extensions from camera labels 

- Load camera calibration from XMP meta data 

- Load camera orientation angles from XMP meta data 

Miscellaneous: 

- Enable rich Python console 

Note: Depth maps add to project file size, and if the goal is to run the workflow described here once 

(no reruns to test point cloud/mesh settings), this option can be disabled. However, if there is a need 

for example, to test different quality settings for Point Cloud generation reusing depth maps would 

save processing time. For this, however, ‘Keep depth maps’ must be selected prior to starting the 

workflow and hence the recommendation. For information on the Metashape settings, please refer 

to Appendix C in the Agisoft Metashape user Manual (Agisoft 2022a). 

  

Figure 3: Update Advanced Preferences. The settings to be checked are highlighted above. 
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Install external packages 
The Python scripts described in this protocol use 3 site packages: exifread, numpy and pyproj, that 

must first be installed in Metashape. Note that the package versions must be compatible with the 

version of Python within Metashape Pro (See Agisoft\Metashape Pro\python\ to find the Python 

version).  

- Package wheels are available on the TERN GitHub repository for Python versions 3.8 

(Metashape Pro v 1.7.x and 1.8.x) and Python 3.9 (Metashape Pro 2.x). Download the zip file 

and unzip to extract the wheels. Install each package as follows. 

- Open a Command (cmd) window as an Administrator. Change directory to folder where the 

wheel files were extracted. Install the 3 packages using: 
“<path to metashape pro>\python\python.exe” -m pip install < 

path to wheel file> 

Example: 
"C:\Program Files\Agisoft\Metashape Pro\python\python.exe" -m 

pip install ExifRead-2.3.2-py3-none-any.whl 

- Note: Ensure that pip is updated if necessary, using: 
C:\Program Files\Agisoft\Metashape Pro\python\python.exe -m 

pip install --upgrade pip 

  

https://github.com/ternaustralia/drone_metashape
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Automated processing workflow 
Python script metashape_proc.py is used to run the Structure from Motion workflow on the P1 and 

MicaSense imagery and generate co-registered orthomosaic tiff files (Table 1 and Table 2). 

Arguments and default values for metashape_proc.py are shown in Table 3.  

Table 3: Arguments and default values used in the Python workflow metashape_proc.py 

Argument 
Type 

Argument Value Default 

Required -crs 

EPSG code of output 
projected coordinate 
reference system. Find the 
EPSG code of the required 
coordinate system. 

NA 

Optional 

-multispec 
Path to multispectral images 
level0_raw folder 

Relative to project location:  
../multispec/level0_raw 

-rgb 
Path to RGB level0_raw folder 
containing the MRK files 

Relative to project location:  
../rgb/level0_raw/ 

-smooth 

Strength value to smooth the 
RGB 3D model.  
 
Select one of low, medium or 
high as appropriate for the 
vegetation on site. For more 
information see notes below 
and examples in ‘Appendix 2: 
Setting the smoothing 
strength value’. 

Low 
 
 

-drtk 

Update ‘rgb’ image positions 
based on post-processed 
DRTK coordinates (blockshift).  
 
Path to txt file containing field 
and AUSPOS Cartesian 
coordinates for DRTK (See 
‘Appendix 3: Process D-RTK2 
base station data’). 
 
 

None  
(image positions are not updated) 

 

  

https://epsg.org/home.html
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Table 4: Example Arguments for metashape_proc.py 

Arguments Interpretation 

-crs “7855”  Use GDA2020 MGA Zone 
55 as output projected CRS. 
Use defaults for image 
folder locations and 
smoothing strength. 
Blockshift is not enabled. 
 

-rgb “G:\SASMDD0009\20220517\imagery\rgb\level0_raw\test" -
multispec  
"G:\SASMDD0009\20220517\imagery\multispec\level0_raw\test" 
-crs "7854" 

Use input paths as 
specified for rgb and 
multispec. Use GDA2020 
MGA Zone 54 as output 
projected CRS. No 
blockshift. 
 

-crs “7855” -drtk “G:\ :\SASMDD0009\20220517\drtk\auspos.txt” 
 

Use GDA2020 MGA Zone 
55 as output projected CRS. 
Use defaults for image 
folder locations, smoothing 
strength. Blockshift using 
coordinates in the 
auspos.txt file. 

 

Setting the Strength value to smooth the RGB 3D model 

Orthomosaics can be built using either a digital elevation model (DEM) or a mesh generated from the 

3D point cloud. The methods and parameters used depend on the complexity of vegetation, and the 

purpose of the orthomosaic (e.g., is geometric accuracy of trees in the orthomosaic important for the 

analysis, or should the trees look ‘aesthetically pleasing’?). Further testing is required to establish 

optimal settings for different environments. Here a polygonal mesh (3D model) is generated from the 

dense cloud, decimated, and smoothed to remove artefacts (e.g., on the edges between tree crowns 

and ground in complex vegetated environments). This smoothed surface generated from the RGB 

model is used as the projection surface for both RGB and multispectral imagery. See ‘Appendix 2: 

Setting the smoothing strength value’ for examples of models of different sites generated with varying 

smoothing strengths. 

• Strength values are 50, 100, 200 respectively for low/medium/high 

• low: for low-lying vegetation (grasslands, shrublands) 

• medium or high: as appropriate for forested sites 
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Run Script 
1. Download scripts metashape_proc.py and upd_micasense_proc.py from the TERN GitHub 

repo. 

2. Open Agisoft Metashape Pro. Save project in format ‘YYYYMMDD_ PlotName.psx’ where 

YYYYMMDD is the date of data acquisition and PlotName is the name of TERN plot. Example: 

20211012_SASRIV0001.psx.  

3. Switch to the ‘Console’ tab to view progress of the script.  

4. Select Tools -> Run Script (Ctrl+R). Under ‘Script’, navigate to the location of the Python 

scripts and select metashape_proc.py.  

5. Under ‘Arguments’, enter the arguments as necessary. Note that the -crs “<EPSG code>” is 

a required argument. See Table 3 for a list of arguments and default values. All argument 

values must be in double quotes “”. It might be helpful to open a .txt file, type and save the 

arguments, and then copy-paste under ‘Arguments’. 

6. Click OK. 

7. Note: If the Metashape window then closes without any error, this is due to a typo in the 

Arguments entered. Check that the argument values are in double quotes. See Table 3 for a 

list of arguments and default values. Use a txt file to type and check the arguments. 

 

 

  

Figure 4: Automated Python workflow: use Tools-> Run Script to run metashape_proc.py. Enter Arguments as required and 
select OK. 

https://github.com/ternaustralia/drone_metashape
https://github.com/ternaustralia/drone_metashape
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8. Monitor progress through the Progress Dialog and the Console tab.  

 

9. When the rgb and multispec chunks are created, the script will be paused for user input on 

Calibration Images for the multispectral data. Select OK on the dialog that appears. 

The following section goes over the steps to locate the calibrated reflectance panel (CRP) and select 

calibration images for the multispectral imagery.  

 

Figure 5: Monitor progress using the Console tab. In the Workspace pane above note that the p1 and micasense chunk 
creation is in progress. 

Figure 6: After the images are added, the script is paused for user input on micasense calibration. The steps to be 
completed are listed on the Console tab. 
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MicaSense: Select calibration images 
10. Prior to interpolating MicaSense positions and deleting extra images, Calibration Images 

must be located and moved to the ‘Calibration images’ camera group so that they do not get 

deleted. Complete steps as per Appendix 4: Reflectance Calibration to select the images to 

be used for calibration. 

Complete processing 
11. Click on the ‘Resume Processing’ button on the toolbar to complete the processing 

workflow. 

 

Figure 7: Click on 'Resume processing' in the toolbar to complete the automated workflow. 

12. Progress will be displayed on the Metashape progress dialog.  

 

 

Figure 8: Script progress displayed in the progress dialog and on the Console tab. 
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13. The remaining steps are completed in the order listed in Table 2. As an estimate of the 

processing times, processing the rgb chunk for a 150 m x 150 m plot takes around 6 hours 

and multispec chunk around 3 hours. Workstation specs:  8 core intel i9-11900 2.5 GHz, 16 

GB dedicated graphics memory (NVIDIA Quadro RTX5000), 2 TB SSD, 128 GB RAM.  

14. When the processing is complete, the RGB and multispectral orthomosaic tif are saved in the 

<sensor>/level1_proc/ folders. If rgb/ and multispec/ folders are not found, files are saved in 

the project folder. Intermediate files are also saved in the project folder.  

 

Figure 9: Workspace pane when p1 and micasense processing is complete.  

 

Figure 10: (a) P1 orthomosaic of a Eucalypt Woodlands TERN plot in Calperum, SA (b) Multispectral orthomosaic of the plot 
with MicaSense Redge-MX Dual NIR band visualised as grey band. The sunlit and dark strips in this orthomosaic are lighting 
artefacts due to varying cloud cover during the drone flight. 

In case of any errors in the workflow, the Console tab (Figure 11) or the log file (selected in Agisoft 

Metashape) will have details on the error and processing step that it appeared on. To fix the error 

and restart processing using the Metashape GUI, refer to ‘Summary of processing workflow using 

Agisoft Metashape’ for equivalent Metashape Toolbar commands. To restart the workflow using a 

Batch Process refer to ‘ Appendix 5: Metashape Batch Process’. 

(a) (b) 
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Figure 11: Monitor script progress on the Console tab. 
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Step-by-step processing using the Metashape GUI 
This section describes the workflow using Metashape GUI commands. Python script 

metashape_upd_cam_pos_only.py is used to update the rgb and multispec camera positions. The 

rest of the workflow is completed manually using Metashape Toolbar commands. 

Add images  
Open Agisoft Metashape Pro. Save project with file name format ‘YYYYMMDD_ PlotName.psx’ 

where YYYYMMDD is the date of data acquisition and PlotName is the name of TERN plot. Example: 

20211012_SASRIV0001.psx.  

1. In the Workspace pane, right-click on ‘Chunk 1’ and rename to ‘rgb’.  

2. Choose Workflow –> Add Folder and add level0_raw folder under rgb/. (Please note that the 

folder and chunk naming is different in the below screenshots which followed an older 

naming convention.)  

3. In the dialog that opens next, select ‘Single cameras’ and OK.  

 

Figure 12: Use the context menu and rename chunk. 
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4. Right-click in the Workspace pane to ‘Add Chunk’. Right-click on the new Chunk and rename 

to ‘multispec’. Active chunks are shown in bold. If the multispec chunk is not active, double 

click on it.  

5. Add multispectral imagery by choosing Workflow -> Add Folder and add level0_raw/ folder 

from the multispectral sensor. 

 

Figure 14: Add folder containing MicaSense images 

Figure 13: Use Workflow-Add Folder and select 'Single cameras' to add P1 images. 

1 
2 
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6. After the photos have been loaded (takes several minutes for large datasets), the following 

window appears. Select ‘Multi-camera system’ and click OK. 

 

Figure 15: Select 'Multi-camera system' and arrange images based on metadata 

7. Any Calibration images automatically detected using the panel QR code will be moved to the 

‘Calibration images’ folder under multispec chunk. Click OK. 

 

Figure 16: Any calibration images detected using the QR code will be moved to a separate folder. 

8. In the main ‘Model’ window, check that the layout of the flight is as expected. MicaSense 

data acquisition is started using a target altitude tolerance so there will be images outside of 

the flight area. These images will be automatically removed in the Python workflow 

(‘Interpolate MicaSense camera positions’).  

 

Figure 17: Check layout of flight in the Model window 
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MicaSense reflectance calibration 
1. Prior to interpolating MicaSense positions and deleting extra images, Calibration Images 

must be located and moved to the Calibration Images folder so that they do not get deleted. 

Complete steps per Appendix 4: Reflectance Calibration to select the images to be used for 

calibration. 

2. After images have been selected and masks checked as per the step above, complete 

reflectance calibration. Open the Calibrate Reflectance dialog again (Tools->Calibrate 

Reflectance). Ensure that ‘Use reflectance panels’ and ‘Use sun sensor’ are checked.  Click 

OK.  

 

Figure 18: Complete reflectance calibration. Select the correct panel. Check 'Use reflectance panels' and 'Use sun sensor' 
parameters. 
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Interpolate MicaSense camera positions 
MicaSense camera locations are based on navigation-grade GPS. Before processing the imagery, the 

camera positions must be interpolated using the P1 positions georeferenced using the on-board 

GNSS RTK. If post-processing of the D-RTK2 base station is required, the script can blockshift P1 

camera positions based on the D-RTK 2 coordinates from the AUSPOS report, and interpolate 

MicaSense camera positions based on the shifted P1 positions.  

Install packages as described in section ‘Install external packages’. Refer to Table 5 for information 

on the arguments and default values. The following steps will be done using python scripts 

metashape_only_upd_cam_pos.py and upd_micasense_pos.py. 

• Update camera positions in ‘rgb’ chunk based on AUSPOS D-RTK coordinates (if enabled 

using -drtk). 

• Convert coordinates to target projected coordinate reference system. 

• Interpolate MicaSense positions using P1 camera positions (sub-second available from MRK 

file). 

• Transform MicaSense coordinates to projected coordinate system to interpolate based on 

P1 coordinates and timestamps. 

• Assign altitude of 0 m to MicaSense images captured outside of P1 acquisition time. Use this 

value to delete these MicaSense images. (Hence the need to first locate Calibration images 

in the previous section to prevent their deletion).  

Table 5: Arguments and default values for metashape_only_upd_cam_pos.py to update P1 and interpolate MicaSense 
camera positions  

Argument 
Type 

Argument Value Default 

Required -crs 
EPSG code of output 
projected coordinate 
reference system 

NA 

Optional -drtk 

Update P1 coordinates using 
the DTK base station post-
processed cooridnates. Pass 
txt file containing field and 
AUSPOS Cartesian 
coordinates for DRTK (See 
‘Appendix 3: Process D-RTK2 
base station data’) 
 
 

None 
(P1 positions not updated) 

 

  



21 
 

Run Script 
1. Download scripts metashape_only_upd_cam_pos.py and upd_micasense_proc.py from the 

TERN GitHub repo. 

2. Switch to the ‘Console’ tab to view progress of the script.  

3. Select Tools -> Run Script (Ctrl +R). Under ‘Script’, navigate to the location of the two Python 

scripts (metashape_only_upd_cam_pos.py and upd_micasense_pos.py) and select 

metashape_only_upd_cam_pos.py.  

 

 

4. Under ‘Arguments’, enter the arguments as necessary.  Note that the -crs “<EPSG code>” is 

a required argument.  See Table 5 for arguments and default values. All argument values 

must be in double quotes ““. It might be helpful to type and save the arguments in a .txt file, 

and copy-paste under ‘Arguments’. 

5. Click OK. 

Note: If the Metashape window then crashes without any error message, this is likely due to 

a typo in the Arguments entered. Check that the argument values are in double quotes. See 

Table 3Table 5 for a list of arguments and default values. Use a txt file to type and check the 

arguments. 

 

Figure 20: Monitor script progress through the Console tab. 

6. Monitor the Console tab for progress of the script. 

7. When the script is complete, in the Workspace pane note that the multispec chunk now has 

fewer cameras as the extra images have been deleted. In the Reference pane, note that the 

Figure 19: Run script to update camera positions in rgb and multispec chunks. 

https://github.com/ternaustralia/drone_metashape
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CRS has been updated to the selected projected CRS. The coordinate columns will have 

updated values based on the P1 RTK locations.  

The following sections go over the rest of the workflow on the Metashape GUI.   
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Zenmuse P1 (RGB) 
In the Workspace pane, double click on the ‘rgb’ chunk to make it active (chunk label must be in 

bold).  

Camera Calibration: GPS/INS Offset 
Select Tools-> Camera Calibration to enter lever-arm offsets. The GNSS RTK georeferencing provides 

the coordinates to the single gimbal position. The offsets from this position to Gimbal 1 (in dual 

gimbal mount) must be entered to account for the offset in gimbal position (Figure 22). For more 

information on this setting refer to the Agisoft Metashape Pro manual (Agisoft 2022a). 

• In the GPS/INS Offset tab, check ‘Enable Reference’. Enter offsets. Offset (m): X: 0.087, Y and 

Z: 0.  

 

Figure 21: Update GPS offsets for P1 from the single gimbal position 

 

Figure 22: GPS offsets as defined in Agisoft Metashape (Source: Agisoft 2022a) 
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Inspect camera settings in the Reference pane 
In the Reference pane, check that the Coordinate System has been updated (EPSG was input to the 

py script in section ‘Run Script’).  

 

Figure 23: Check that the CRS has been updated as per input to the script. 

• Click on ‘Settings’ icon. Update ‘Camera accuracy’ to 0.1m which is the expected accuracy 

for M300 GNSS RTK. 

  

Figure 24: Update camera accuracy to 0.1 m 
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Disable cameras with low Image quality 
In Metashape, Image Quality can be calculated based on the sharpness in the most focused part of 

the picture. Metashape recommends that images with low quality value be excluded. 

• In the ‘Photos’ tab, select ‘Details’ view. Right-click on any image to ‘Estimate Image Quality’. 

In the ‘Analyze Photos’ dialog, select Apply to ‘All cameras’.  

• When this step is complete, sort photos based on ‘Quality’ column. Inspect images with 

Quality less than 0.7. Right-click on these image(s) to ‘Disable cameras’.  

 

Figure 25: Estimate image quality for all cameras. 

• Review the camera layout in the main window. Remove images captured when the drone 

was turning at the end of flight lines.  

 

Figure 26: Remove extra images at the end of flight lines 
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Note on Batch processing: Many of the following steps can be automated using a batch script 

through Workflow -> Batch Process menu. See ‘Appendix 5: Metashape Batch Process’ for an 

example using Batch Process once both the chunks have been setup. Here, the steps are listed 

separately for the RGB and multispectral chunks. 

 

Align Photos 
Image alignment is done to estimate the exterior and interior orientation parameters based on 

bundle block adjustment (please refer to Agisoft 2022a for more information on this process). 

Select Workflow->Align Photos. Use the settings as shown in the image below:  

• Accuracy: ‘High’  

• Reference preselection: ‘Source’. Select overlapping pairs of images based on the measured 

camera coordinates. This is recommended as camera locations georeferenced with high 

accuracy are available. 

• Uncheck ‘Generic preselection’. When enabled, overlapping pairs of images are selected by 

matching photos at a lower accuracy setting first. However, in drone surveys of TERN plots, 

where only a few tie points might be detected at the image matching stage, using only 

Reference preselection without Generic preselection is recommended by Metashape.   

• Use default limits for key point and tie points. These indicate the upper limit of feature points 

on every image during the image matching process. 

At the end of this step, a tie point cloud will be generated which can be used to visualise the 

alignment results. 

 

Figure 27: Align Photos with Accuracy: High, Reference preselection set to Source. 
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Optimise Camera Alignment 
This step performs a full bundle adjustment on the aligned images based on available measurements 

and camera accuracies and can improve the results of the alignment. 

• In the Reference pane, ensure that all cameras to be used for optimisation are checked (this 

is the default setting). Camera accuracy settings were updated earlier in this workflow.  

• Click on the ‘Optimize Cameras’ icon.  

• Use the default settings (shown in figure below):  

o General: Fit f, k1, k2, k3, cx, cy, p1, p2 

o Disable Advanced settings 

For more information on the values being optimised, refer to the Agisoft Manual (Agisoft 2022a). 

 

Figure 28: Optimise alignment using default settings. 
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Build Point Cloud  
A dense cloud can be built using the estimated camera positions. Depth maps calculated for the 

overlapping image pairs are used to generate a dense point cloud.  

Select Workflow -> Build Point Cloud (if using Agisoft Metashape Pro version 1.x, select Workflow -> 

Build Dense Cloud instead), and enter settings as follows: 

• Quality: Medium. Higher quality settings result in a more detailed geometry but require 

longer processing times.  

• Depth filtering: Mild. Depth filtering mode sets the level of noise filtering, Mild or Moderate 

are useful for these datasets. Whereas Aggressive could remove more points than intended 

and Disabled will result in a very noisy point cloud. 

   

Figure 29: Build point cloud using mild filtering and medium quality 

Orthomosaic generation 
Orthomosaic can be built using different orthorectification surfaces, for example: 

1. Ground surface generated from lidar point cloud. 

2. Ground points classified in the photogrammetric point cloud in Metashape, and the resulting 

surface built from ground points can be used as the orthorectification surface. 

3. The dense photogrammetric point cloud can be used to reconstruct a 3D polygonal mesh 

model which can be used as the surface. 

4. The surface model as above smoothed to remove artefacts due to sharp differences in height 

e.g., canopy edges. 

The surface used depends on the intended use of the orthomosaic e.g., is geometric accuracy of trees 

in orthomosaic important for the analysis? It is also likely to be determined by the complexity of 

vegetation on the site. For example, classifying ground points in the photogrammetric point cloud 

tends to have poor results in densely vegetated sites. Further research/testing is required to establish 

optimal settings for different environments.  
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Here a polygonal mesh is generated from the dense cloud. The mesh is smoothed to remove artefacts 

(e.g., on the edges between tree crowns and ground in complex vegetated environments) and used 

to project both the RGB and multispectral imagery.  

Build Mesh 
Select Workflow->Build Mesh.  

• Source data: Point cloud (if using Metashape Pro version 1.x, select Dense Cloud) 

• Surface type: Height field. The surface type is optimised for modeling planar surface rather 

than an arbitrary object. 

• Face count: Medium. Used to identify the maximum number of polygons in the final mesh. A 

low value might be appropriate (in which case the decimate mesh step below could be skipped) 

but needs further testing to compare results (To do list).  

• Use default values for other settings. 

• On Metashape Pro version 2.x, in the dialog box that appears next, click on ‘Yes’ to build the 

mesh from the point cloud. 

  

Figure 30: Build mesh from dense cloud. Surface type: Height field, face count: Medium. 

The aim is to create a smooth surface to project the images. With the medium quality mesh, this is 

done by decimating and smoothing the mesh surface as follows.  

Decimate Mesh: Select Tools-> Mesh->Decimate mesh. Enter an appropriate value, for example, to 

halve the number of faces in the original mesh. 
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Smooth Mesh: Select Tools ->Mesh->Smooth mesh. The strength of smoothing depends on the 

complexity of canopy, hence smoothing must be done in iterative steps. Three values are 

recommended for low, medium, and high smoothing: 50, 100 and 200 respectively. Further testing 

on data from densely vegetated sites is required to ensure these settings are appropriate for those 

environments (see To do list). 

To smooth the mesh in iterative steps, start with a small Strength value, inspect the smoothed model, 

build orthomosaic from each mesh to compare the results. To avoid overwriting the default mesh, 

first duplicate the mesh using the context menu. 

 

Figure 31: Smooth the mesh in iterative steps. 

Export Model  
The RGB smoothed model will be used as the surface for MicaSense orthomosaic generation as well 

to ensure consistency.  

• Right click on the smoothed 3D model to export the model.  

• Under Coordinate System enter the output projected target CRS. Use default values for 

other settings. 

• Save as obj file in the Metashape project directory. Recommended naming format: 

<project_name>_rgb_smooth_<smooth_strength_value>.obj 

 

Figure 32: Export smoothed model as .obj file in the target projected CRS. 
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Build Orthomosaic  
In this step the images are stitched together by merging the original images projected on to the 

smoothed mesh. 

• Using the context menu in the Workspace pane, ensure that the smoothed 3D Model is set as 

default.  

• Select Workflow->Build orthomosaic.  

• Surface: Mesh.  

• Enable ‘Refine seamlines’: this will ensure the automatically created seamlines bypass 

complex vegetation and avoid visual artefacts in the orthomosaic.  

• Use the default pixel size (m).  

 

Figure 33: Build orthomosaic using the smoothed mesh 
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Export Orthomosaic  
After the Orthomosaic is generated, in the Workspace pane, right-click on the orthomosaic and 

select Export Orthomosaic -> Export JPEG/TIFF/PNG.   

• Update the Pixel size (round the default resolution to 2 places).  

• Select options: ‘Write tiled TIFF’, ‘Write BigTIFF file’, ‘Generate TIFF overviews’ 

• Accept other default settings   

• Save the tiff in rgb/level1_proc/ directory. Recommended naming format is 

<project_name>_p1_ortho_<resolution_in_m>.tif 

 

Figure 34: Export Orthomosaic and save as tiff file in rgb/level1_proc/ 
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RedEdge-MX/MicaSense Dual (Multispectral) 
In this section, screenshots are included only where settings/parameters vary from the steps used 

for RGB imagery processing in the previous section.   

Camera Calibration: GPS/INS Offset 
Select Tools-> Camera Calibration.  

• Enter lever-arm offsets (from the single gimbal position). In the GPS/INS Offset tab, check 

‘Enable Reference’. Enter offsets (m) as follows: 

o MicaSense RedEdge-MX (X, Y, Z): -0.097, -0.03, -0.06 

o MicaSense Dual (X, Y, Z):  -0.097, 0.02, -0.08 

 

Figure 35: Enter GPS offsets for MicaSense from the single gimbal position 

Inspect camera settings in the Reference pane 

• In the Reference pane, check that the Coordinate System has been updated (as per the EPSG 

input to the py script in ‘Update Camera positions using python script’). 

• Click on ‘Settings’ icon. Update ‘Camera accuracy’ to 0.1m. 
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Change Primary Channel and adjust Brightness 
For multispectral imagery the main processing steps (e.g., Align photos) are performed on the 

primary channel. Change the primary channel from the default Blue band to NIR band which is more 

detailed and sharp.  

• Select Tools-> Set Primary Channel. Choose NIR band from the dropdown list.  

• Adjust image brightness and contrast for better display. Select Tools-> Set Brightness and 

click Estimate and then OK.  

 

Figure 36: Update Primary channel to NIR and estimate Image brightness. 

Disable cameras with low Image quality 

• In the ‘Photos’ tab, select ‘Details’ view. Right-click on any image to ‘Estimate Image Quality’. 

In the ‘Analyze Photos’ dialog, select Apply to ‘All cameras’.  

• When this step is complete, sort photos based on ‘Quality’ column. Inspect images with 

Quality less than 0.7. Right-click on these image(s) to ‘Disable cameras’.  

• Review the camera layout in the main window. Remove images that were captured when 

the drone was turning at the end of flight lines.  

Align Photos 
Select Workflow->Align Photos.  

• Accuracy: ‘High’ 

• Reference preselection: ‘Source’.  

• Uncheck ‘Generic preselection’.  

• Use default limits for key point and tie points. 

Optimise Camera Alignment 
In the Reference pane, ensure that all cameras to be used for optimization (by default, all) are 

checked. Click on the ‘Optimize Cameras’ icon. Use default settings (Figure 28). 
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Set Raster Transform 
To generate an orthomosaic with the reflectance value normalised between 0 and 1, a raster 

transform must be applied. The pixel values are proportional to % reflectance, with a pixel value of 

32768 being equal to 100% reflectance (65535 is equal to 200 % reflectance). So, to generate the 

reflectance values the pixel values must be divided by 32768. 

• Select Tools -> Set Raster Transform.  

• To generate an orthomosaic with relative reflectance, in the Transform tab, enter the 

expression B<num>/32768 for each band as shown in the figure below. A pixel value of 

32768 is equal to 100 % reflectance and 65535 is equal to 200 % reflectance. To extract 

reflectance values normalised to 0 – 1 range, divide the source value by 32768 (Agisoft 

2022b).  

• Select ‘Enable transform’. 

 

 

Figure 37: Update Raster Transform to generate an orthomosaic with relative reflectance values. Check 'Enable Transform'. 
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Import Model 
Select File->Import->Import Model and select the .obj file that as exported during RGB imagery 

processing (Export Model). Under Coordinate System select the target CRS used during export. 

  

Figure 38: Import smoothed RGB model into multispec chunk 
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Build Orthomosaic 
Select Workflow->Build orthomosaic.  

• Surface: Mesh  

• Enable ‘Refine seamlines’  

• Accept other default settings 

Export Orthomosaic  
Right-click on the orthomosaic and Export JPEG/TIFF/PNG.   

• Under Raster Transform, select ‘Index value’ to export the relative reflectance values  

• Update Pixel size with the desired resolution of the orthomosaic  

• Select options: ‘Write tiled TIFF’, ‘Write BigTIFF file’, ‘Generate TIFF overviews’ 

• Accept other default settings   

• Save the file in the level1_proc/ folder under multispec/. Recommended naming is 

<proj_name>_multispec_ortho_<resolution_in_m>.tif. 

 

Figure 39: Export orthomosaic. Set Raster transform to 'Index value' to export values set using the formula in previous step. 
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To do list 
1. Surface used to project images: test and compare results using low quality mesh, medium 

quality mesh with decimating and smoothing, etc. on different datasets.  

2. Compare orthomosaic from smoothed mesh and Lidar DEM by digiting tree canopies and 

comparing canopy metrics. 

3. Test smoothing strength values (low, medium, high) and orthomosaic generation in sites 

with high vegetation structure/complexity. 

4. Processing data on revisits: Test adding revisit data as different camera groups in Metashape 

and use one set of cameras (from the first visit) for alignment. 

5. Test dense cloud classification (settings suggested by Matt Dell) with low-strength 

smoothing in sites with dense vegetation. Noting that in previous tests, classifying ground 

points in Metashape did not lead to good results in these sites with ultra-high resolution 

drone data.   

6. Batch script to install external packages. 

7. Low priority (revisit if D-RTK2 processing is done frequently for TERN datasets): script to 

create text file and do some of the D-RTK2 processing in a single step. 
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Appendix 1: Note on folder structure 
The automated Python workflow relies on the following folder structure. Raw data must be saved in 

<plot>/YYYYMMDD/imagery/<sensor>/level0_raw/ (Table 6). Orthomosaic generated using the 

automated workflow will be saved in rgb/level1_proc/ and multispec/level1_proc/ 

Table 6: Automated Python workflow relies on the following directory structure for raw data. Processed data and 
Metashape project will be stored as shown below. 

Data Path 

Raw data <plot>/YYYYMMDD/imagery/<sensor>/level0_raw/ 
Example: 

SASMDD0001/20220519/imagery/rgb/level0_raw/ 

Data products <plot>/YYYYMMDD/imagery/<sensor>/level1_proc/ 
Example: 

SASMDD0001/20220519/imagery/multispec/level1_proc/ 

Metashape project plot/YYYYMMDD/imagery/metashape/ 
Example: 

SASRIV0001/20220516/imagery/metashape/ 

DRTK logs plot/YYYYMMDD/drtk/ 
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Appendix 2: Setting the smoothing strength value 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 40: (a) High resolution 3D model of a Samphire shrubland TERN plot. (b) 3D model visualised without shading. (c) Model decimated and smoothed with ‘low’ strength value 50 to create an orthorectification surface.  

(a) (b) (c) 
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Figure 41: (a) High resolution 3D model of a Eucalypt Woodlands plot in Calperum with average vegetation height ~ 15 m. (b) The 3D model visualised without shading. (c), (d), (e) Default model when decimated and smoothed with low, medium, and high strength values respectively.  

(a) (b) 

(c) (d) (e) 
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Appendix 3: Process D-RTK2 base station data 
Raw GNSS data from the D-RTK2 can be post-processed using AUSPOS to refine the position of the 

base station. Note that if the D-RTK2 battery was changed, the base location recorded would change 

although the base station was not moved. In this case the logs (before and after the battery change) 

must be processed separately. 

1. Connect the D-RTK2 via USB to a laptop/computer and copy the RTCM .DAT files from the 

DRTK2 ‘rtcmraw’ directory on the device and copy D-RTK2 log files to 

<plot>/<YYYYDDMM>/drtk/ 

2. RTK files must be converted to RINEX format and consolidated into a single OBS file (an OBS 

file created for every hour of observations). The merged OBS file must be submitted to 

AUSPOS for processing.  

3. RTK files will be converted and consolidated using RTKLIB. Download RTKLIB version 2.4.3 

b34 from http://www.rtklib.com/.  

4. Open command prompt on Windows. Either use the path to convbin and teqc executables in 

the following commands or update PATH environment variable to include path to the RTKLIB 

location using: 

set PATH = %PATH%;<path to rtklib location> 

5. convbin.exe converts the DAT file to RINEX format and generates OBS and NAV files. Replace 

‘OUTPUT_DIR’ with the drtk/ folder. 

convbin.exe -r rtcm3 -v 2.11 *.DAT -d OUTPUT_DIR -od -os 

-oi -f 2 

convbin.exe -r rtcm3 -v 2.11 

RTK029_202109160400_13ALH63005007V.DAT -d 

P:\test_cui_rtklib -od -os -oi -f 2  

Note that teqc.exe can be used to consolidate multiple OBS files into one file that can be 

sent to AUSPOS for processing.  

teqc.exe ENTER_LIST_OF_OBS_FILES_HERE > DRTKBase.obs 

teqc.exe RTK*.obs > DRTKBase.OBS  

Or, if only some of the OBS files are to be used, list them separately: 

teqc.exe RTK027_202109160256_13ALH63005007V.obs 

RTK028_202109160300_13ALH63005007V.obs 

RTK029_202109160400_13ALH63005007V.obs > DRTKBase.OBS 

6. Decimate OBS file which was sampled at 1 second to 30 seconds as required by AUSPOS. 
teqc.exe -O.int 1 -O.dec 30 DRTKBase.OBS > 

DRTKBaseSubSamp30.OBS 

 

7. Go over the Checklist at https://www.ga.gov.au/scientific-topics/positioning-

navigation/geodesy/auspos. Under ‘AUSPOS Submission’, click on ‘Submit your data to 

AUSPOS’. 

 

  

http://www.rtklib.com/
https://www.ga.gov.au/scientific-topics/positioning-navigation/geodesy/auspos
https://www.ga.gov.au/scientific-topics/positioning-navigation/geodesy/auspos
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8. Enter the following information (Figure 42):  

• Click ‘Choose File(s)’ to select the OBS file(s). 

• Leave the Antenna Height as 0, Antenna Type as ‘DEFAULT (NONE)’. 

• Enter the email address to which the AUSPOS report will be sent. 

 

 

Figure 42: Submit OBS file on AUSPOS. Leave Antenna Height as 0, Antenna Type as DEFAULT (NONE). 

9. The output report will be received via email; save the report(s) in the drtk/ folder.  

10. Create a .txt file in drtk/. Copy and paste the Cartesian coordinates for D-RTK2 from the 

RINEX OBS file and AUSPOS report (See section Cartesian, GDA2020).  
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11. In the .txt file, the first line must be the comma separated cartesian coordinates from 

RINEX OBS file and the second line the coordinates from AUSPOS report. 

 

Figure 43: Create .txt file with D-RTK2 Base coordinates from the field the OBS file, and the coordinates from the AUSPOS 
report. Note that the coordinates must be separated by commas in the .txt file. 

12. This txt file can be used in the Python workflow (see ‘Summary of processing workflow using 

Agisoft Metashape’) to update camera positions. On Agisoft Metashape the difference 

between the AUSPOS and field positions for the base station will be applied to blockshift the 

P1 camera station positions.  
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Appendix 4: Reflectance Calibration 
Images of the calibrated reflectance panel must be located and moved to the Calibration images 

camera group. When panel codes are not detected automatically, masks must be selected manually 

on all bands of each calibration image. It is also recommended to check that the masks have been 

set correctly even for cases where panels have been automatically located. This section covers the 

steps involved. 

Note that the following screenshots are from 10-band MicaSense Dual sensor and hence may look 

different to what is displayed for 5-band RedEdge-MX.  

1. Select Tools -> Calibrate Reflectance. Select ‘Locate panels’. This step is necessary to locate 

the panels even if calibration images have been automatically moved to the Calibration 

Images group.  

 

Figure 44: Calibrate reflectance. Select Locate Panels to locate images and set masks for the panels. 

2. When the ‘Locate panels’ step is complete: 

a.  check that the ‘Panel’ is the CRP model that was used in the field (look for the 

correct serial number e.g., ‘RP06…’). The first time this is done, the csv with the 

panel reflectance values will have to be uploaded. Select the correct csv file from the 

local drive. If panel reflectance values are unavailable, contact MicaSense.  

b. Check that all panel images were located for all bands. For example, in Figure 45 

‘RP06… (10/10)’ for 10-band Dual sensor indicates that the calibrated panel was 

located in all 10 bands of the image (or (5/5) for RedEdge-MX images). If not all 

bands were located, the display will indicate how many bands the panels were 

located in (x/10). The mask will have to be manually selected (following steps).  

3. Click ‘Cancel’. Before reflectance calibration is done, panel masks must be checked, and 

calibration images chosen from either pre or post flight.  

https://support.micasense.com/hc/en-us/requests/new
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Figure 45: When the panel/images have been located, press Cancel. 

4. In the Workspace pane, navigate to the Calibration Images group within ‘multispec’ chunk. 

Inspect the photos and identify the ones to use for reflectance calibration.  

a. These images must be sharp and without shadows on the panel.  

b. Check that the entire panel is covered in the image. (If it is not, remove the image by 

using the context menu and ‘Remove Camera’).  

c. Click on ‘Show Masks’ in the photo menu and inspect the mask set by default. Only the 

panel must be unmasked.  

 

Figure 46: Open calibration images from the folder in multispec chunk to choose images from either pre or post flight. Select 
images where the entire panel is covered. 

Entire panel 

not covered in 

the image – 

remove this 

image from 

‘Calibration 

images’. 

Check that the 

entire panel is 

covered in the 

image. 

Ensure that 

only the panel 

is unmasked. 
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Figure 47: Use the 'Show Masks' icon to inspect the default mask set for the calibration images. 

5. Create panel mask manually: When the panel code is not fully visible in the calibration 

image, the panel will not be located automatically in those bands of an image (In Figure 48, 

panels were located only in 9/10 bands of IMG_0000 and in 7 bands of IMG_0001).  

In these cases, as well as when the automatically detected mask was incorrect, mask needs 

to be created manually.  

6. Steps to update the panel mask are shown in Figure 49 and Figure 50. 

 

 
 

 

 

Figure 48: Calibrated panel was not located in all bands of these 2 calibration images. The band images must be examined, 
and mask set manually as required. 
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Figure 49: Steps to manually create panel mask when panel was not automatically located, or when default mask is incorrect. 

1. In the Photo menu, click on ‘Rectangle 

Selection’. 

2. Select the calibration image. Note that if images 

were not located through ‘Locate panels’ they 

must first be selected and moved to a ‘Calibration 

images’ camera group. Select the band for which 

mask is to be set/updated. On Metashape v2.x, 

this can be done using the panel of images on the 

right. On earlier versions, use Tools-Set Primary 

Channel to set and display each band iteratively. 

3. Select the relevant band for which mask is to be 

set/updated. On Metashape v2.x, this can be done 

by navigating the right panel of images for all 

bands On Metashape v1.x.x, use Tools - Set 

Primary Channel to iteratively select each band 

and update the mask. 
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 4. If a mask has already been set and it is 

incorrect, first reset this by right clicking 

on image and selecting ‘Reset Mask’ (Not 

shown in image). 

5. Select the panel area (using rectangular 

selection tool enabled in step 1). 

6. Right click on the image and select ‘Add 

Selection’. 

7. Right click on the image and select ‘Invert 

Mask’. 

8. The mask should now only contain the 

panel area. 

9. Repeat steps for other bands and other 

calibration images.  

10. Mask images can be saved using right click 

on image in the Workspace Pane, select 

Masks - Export Mask. Save as single 

channel mask image. This will save mask 

images of all bands. 

Figure 50: Continuation of steps to create panel mask. 
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7. Ensure that the above steps are repeated for other channels. On Metashape v1.x.x change 

the channel displayed using Tools -> Set Primary Channel. On Metashape Pro v2.x, use the 

right pane to open other bands and update masks. Repeat the above process for all bands 

on other calibration images. 

8. Ensure that the calibration images selected were taken at a time (either from before or 

after flight) that best represents the illumination condition during the flight. Finally, select 

images that will not be used for calibration, right-click and select ‘Remove Cameras’.  

 

  

Figure 51: Remove images that are not to be 
used for calibration. 
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Appendix 5: Metashape Batch Process 
To run Metashape processing in a batch, the commands in Table 2 can be added as a Batch Process using the 

following example workflow. 

1. Select Workflow -> Batch Process. In the dialog select ‘Add’ to add jobs.  

 

Figure 52: Start a batch process 
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2. In the Add Job dialog, select the job type from the dropdown list. Select the chunk(s) to run the job on. In the 

Parameters box, update the settings. Click OK. 

3. Repeat the steps to add more jobs. When all jobs have been added, check that the order of the jobs and the 

chunks they apply to are correct. Use the arrow keys to change the order of the steps. Check the ‘Save 

project after each step’ box. Click Ok.  

4. Run the batch process in the background (click on Background). Progress can be monitored using the 

Console tab. 

  

 

 

Figure 53: Add jobs, select chunks, and update parameters for each job. Select OK. Add more jobs as required. Select 
‘Save project after each step’. Click OK to start the jobs. 
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Appendix 6: Processing workflow using a custom Metashape window 
This section describes another approach where a custom processing menu is used to run the same workflow. User 

input is still required to inspect and select calibration images, information on these steps is provided on-screen. 

• Install package PySide2 in Metashape (see ‘Install external packages’) 
• Copy metashape_proc_widget.py and upd_micasense_pos.py to 

C:\Users\<username>\AppData\Local\Agisoft\Metashape Pro\scripts\ 

• Open Agisoft Metashape Pro. Switch to the ‘Console’ tab to view progress of the script.  

• A custom option ‘Metashape processing menu’ would appear on the toolbar. Click on it to open the 

‘Metashape processing’ window. There are four steps to complete as shown in Figure 54. These steps are 

described in the rest of this section.  

 

 

 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Figure 54: 'Metashape processing menu' appears on the toolbar when Metashape Pro is opened. The four steps in the workflow are 
shown above. 
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Add images 
1. Click on Add images in the custom window. In the dialog that opens, click on ‘Create chunks’. Select the 

folder where the rgb/ and multispec/ folders are located. This will create chunks rgb and multispec and add 

the images. The progress dialog displays the overall progress. 

 

When all the images have been added, a dialog appears to ‘Specify the project name’ (default location of 

imagery/metashape in the plot folder). Enter a name in the format YYYYMMDD_PlotName.psx (YYYYMMDD 

is the date of data collection) and click Save. 

 

  

Figure 55: Step 1: 'Add Images' and select the folder with the rgb/ and multispec/ folders 

Figure 56: After the images have been added, when prompted enter a name for the Metashape project. 
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Select calibration images 
2. The next step requires user input to select the calibration images for micasense reflectance calibration. In 

the Metashape processing window, click on ‘Info on steps to complete’. Complete Steps 1 to 3 listed. Note 

that this window can be left open while the steps are completed using the Metashape toolbar. (For 

screenshots of these steps, refer to MicaSense reflectance calibration.) Select OK when done. 

 

Figure 57: Step 2: Follow onscreen information to Locate panel and select calibration images. 

Run the processing workflow 
3. Check both the buttons to mark the steps complete. Enter the EPSG code of the output projected CRS. Select 

Strength value to be used to smooth the RGB 3D model. If blockshift of P1 images is necessary, select the 

option and browse to select the txt file containing the cartesian coordinates from the field and AUSPOS (See 

Process D-RTK2 base station data). 

4. Select Run. 

 

 

 

  

Figure 58: Enter the EPSG code for the projected target CRS, select a smoothing strength for the P1 3D model. Click Run to start 
the workflow. 
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5. Progress will be displayed on the Metashape progress dialog. When processing is complete, the RGB and 

multispectral orthomosaic tif are saved in the <sensor>/level1_proc/ folders. Intermediate files are saved in 

the project folder.  

 In case of any errors in the workflow, the log file (selected in Agisoft Metashape) and the Console tab will have 

details on the error and processing step that it appeared on. To fix the error and restart processing using the 

Metashape GUI, refer to ‘Summary of processing workflow using Agisoft Metashape’ for equivalent Metashape 

Toolbar commands. To restart the workflow using a Batch Process refer to ‘Appendix 5: Metashape Batch Process’.  
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Revision History 

Date Revision Changes 

24/09/2021 1.0 Initial version 

04/11/2021 1.1 Updated after review by Darren 

15/11/2021 1.2 Updated after Oval trial flight 

18/11/2021 1.3 Formatting updates 

09/02/2022 1.4 Updates following review by Shaun Levick 

12/05/2022 1.5 Update to D-RTK 2 processing when base station battery was changed.  
Highlight that MRK files must be copied to a path when more than 1 flight.  
Specified GPS/INS fields in Summary table. 

02/08/2022 2.0 Updates following Calperum campaign in May 2022 

03/11/2022 3.0 Updates following reviews from team 

08/05/2023 3.1 Changes for Metashape Pro 2.x.x release. Minor updates to workflow 
(e.g., single option ‘drtk’ instead of ‘blockshift’ and ‘drtk’).  

 

 


